Eclipse PDT Cocoa-64bit

Après mon passage sous Snow Leopard, je me suis dit qu’il serait bon de pouvoir utiliser des applications 64 bits. Pour le developpement Web/PHP, j’utilise l’IDE Eclipse PDT All In Ones. Malheureusement, il n’existe pas de version de PDT All In Ones en version cocoa-64bit. Qu’à cela ne tienne, il est tout à fait possible d’installer très simplement PDT à partir d’une version d’Eclipse  « Classic », qui elle, existe en version cocoa-64bit.

1. Installation d’Eclipse Classic

La première chose à faire est donc de télécharger Eclipse Classic 3.5.0 (Mac Cocoa 64bit).
Une fois l’archive d’Eclipse décompressée, lancer Eclipse.

2. Installation du plugin PDT

Pour installer PDT, utilisez le menu « Help > Install New Software… ».

Allez dans « Available Software Sites », tapez « pdt » au niveau du filtre puis rendez « active » (Enabled) l’adresse suivante http://download.eclipse.org/tools/pdt/updates/2.0/ puis cliquez sur « ok ».

Available Software List

Dans la section PDT SDK 2.1.2, sélectionnez « PHP Development Tools (PDT) Runtime Feature » puis valider l’installation en cliquant sur « finish ».

eclipse_pdt_install

Une fois le plugin installé, redémarrez Eclipse quand il vous le suggérera.

Voilà, vous disposez d’une version Cocoa-64bit d’Eclipse avec PDT.

3. Compléments d’installation

3.1. Subclipse, client SVN

Comme pour installez PDT, utilisez le menu d’Eclipse « Help > Intall New Software…  » :

Tapez l’url suivante "http://subclipse.tigris.org/update_1.6.x"

Eclipse Subclipse Install

Selectionnez les différents composants à installer (tous ici, mais ce n’est pas obligatoire) :

Eclipse Subclipse

Redemarrez Eclipse après l’installation du plugin.

3.2. Mylyn, gestion de tâches

Pour allez plus loin, nous pouvons compléter l’installation par le plugin Mylyn, qui nous permettra d’intégrer une gestion de tâches (Bugzilla, Trac, JIRA, Redmine) au sein de l’IDE.

Utilisez le menu « Help > Install New Software… ».

Tapez « mylyn » au niveau du champ « work with », selectionnez l’adresse "http://download.eclipse.org/tools/mylyn/update/e3.4", et cochez les composants comme ci-dessous.

Eclipse Mylyn Install

Comme pour toute installation de plugin, redémarrez Eclipse.

Vous disposez maintenant d’une version comparable à celle fournie par Eclipse PDT All In Ones, mais en utilisant Cocoa-64bit.

1 réponse à Eclipse PDT Cocoa-64bit

  1. le novembre 13, 2009 à 9:36 , Fabien dit:

    Les versions 64bits pour OSX sont maintenant toutes disponibles.

    http://www.eclipse.org/downloads/

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *